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Changes from SolidWorks 2003 to  

SolidWorks 2004 
 

The changes from SolidWorks 2003 to SolidWorks 2004 are primarily cosmetic. 
Consequently, it is quite easy to use the current edition of Learning SolidWorks (copyright 2004 
edition) with the latest version of SolidWorks 2004.  

 
The most prominent change in the look of SolidWorks is that many of the pop-up dialog 

boxes in SolidWorks 2003 have been replaced with the PropertyManager in SolidWorks 2004. 
Fortunately, the options within the PropertyManager are very similar to those in the dialog 
boxes. The look is just a bit different. 

 
This guide is helpful in using Learning SolidWorks with SolidWorks 2004. All significant 

changes in SolidWorks that affect the tutorial in the book are listed below. In addition, there are 
many very minor changes, such as slight differences in toolbar buttons and menu item names. 
Since these changes are barely noticeable and do not affect the tutorial, we do not include them 
here.  

 
We recommend that you print out this document and mark the pages in the book that are 

noted below. When you proceed with the tutorial in Learning SolidWorks, you can simply refer 
to this document when you get to any of the marked pages. 

 
To find out about the latest features in SolidWorks 2004, click Help ⇒ ⇒ What’s New 

Manual or Help ⇒ SolidWorks Help Topics ⇒ What’s New in SolidWorks 2004. The 
document that appears contains information on changes, new features, and working examples 
that are helpful in transitioning to the new version. 

 
 
 
 

SOFTWARE NOTICE – Ensure the latest software update of SolidWorks is installed on your machine for 
the features in the tutorial to work properly.  At a minimum, Service Pack 4 (SP4) should be used. 
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2.1.2 Checking the Options Settings Page 11  
 
5. The Sketch, Sketch Relations, and Sketch Tools toolbars are now all combined into the Sketch 

toolbar. Ensure that the Sketch toolbar is checked along with the other toolbars shown in 
Figure 2.4.  

 
SolidWorks 2004 introduces the CommandManager, which contains contextual feature and 
modify commands for use while creating parts, assemblies, and drawings.  In order to follow this 
tutorial, the classic toolbar buttons and menu items will be used. If the Command Manager is 
checked in View ⇒ Toolbars, close it by unchecking View ⇒ Toolbars ⇒ 
CommandManager. 

 
 
2.2.1 Creating a New Part Pages 12 
 

1.  At the end of this step note the following:  SolidWorks 2004 introduces the CommandManager, 
which contains contextual feature and modify commands for use while creating parts, assemblies, 
and drawings.  In order to follow this tutorial, the classic toolbar buttons and menu items will be 
used. If the Command Manager is checked in View ⇒ Toolbars, close it by unchecking View 
⇒ Toolbars ⇒ CommandManager. 

 
 2. The initial orientation when a part is opened may be Isometric, which means that the Front, Top, 

and Right planes appear as angled planes in the Graphics Window.  In order to see the planes 
as described in this section, click the Standard Views toolbar button (a cube with red arrows).  
Then click Front to reorient the model to the front view.  This will make the Front plane 
coincide with the plane of the screen, Top the horizontal plane, and so on. 

 
 

2.2.2 Sketching Pages 14-16 
 

1. The Sketch toolbar, as mentioned above, now incorporates the Sketch Relations and Sketch 
Tools toolbar buttons as well as the Sketch toolbar buttons.  In addition, the Select toolbar 
button (an arrow) has moved to the Standard toolbar, and the Grid button is no longer 
available.  The new Sketch toolbar is shown below.  It may be oriented vertically along one 
side of the Graphics Window. 

 
 

 
 

Figure 2.7. Sketch toolbar. 
 

2. The Grid button is no longer located in the Sketch toolbar. Instead of using the Grid button, 
access the System Options and Document Properties settings using Tools ⇒ Options instead. 

 
 In the Document Properties dialog box, the Units settings are controlled differently. To match 

the settings used in this tutorial, click Units on the left side of the dialog box.  Then 
• Set the Unit System to Custom 
• Set the Length Units as described for Linear Units in the tutorial 
• Set the Dual Units as described for Linear Units in the tutorial 
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IN ADDITION – The expanded Sketch toolbar (which now includes Sketch Relations and Sketch 
Tools), the Tools ⇒ Options menu item instead of the Grid button, and the updated Units settings are 
used throughout the tutorial, including Paragraphs 2.2.2.4, 2.2.2.5, 2.2.3.1, 2.3.1.2, 2.3.4.1, 2.4.2.1, 
3.2.5.5, 4.2.1.2, 6.2.1.4, and 7.1.1.1. 

 
3. When creating a new sketch, the default sketching plane is no longer the Front plane. When you 

click the Sketch toolbar button, a message will appear on the left side of the screen requesting a 
plane on which to create a sketch. Select the Front plane in the Graphics Window or in the 
Feature Manager Design Tree to begin sketching on the Front plane. 

 
IN ADDITION – When creating the first feature of a part throughout this tutorial, select the Front plane 
as described above.  This includes paragraphs 2.3.1.4 and 2.4.1.1. 

 
 
2.2.6 Extruding the Cross Section Page 25 
 

3. Several of the viewing commands and toolbar buttons have been updated.  Instead of using View 
⇒ Display ⇒ HLR Edges In Shaded Mode to remove the lines on the edges of parts, simply 
click Shaded in the View toolbar. 

 
2.2.7 Viewing the Guard Page 25-26 
 

Several of the viewing commands and toolbar buttons have been updated.  Use these features to 
match the views in this tutorial: 

• To show the edges in shaded mode, click Shaded With Edges. 
• The View Orientation toolbar button is now located in the Standard Views toolbar. 
• Two new views show the model in different angled orientations, Trimetric and Dimetric, 

which are located in the Standard Views toolbar. 
• The View toolbar includes a new feature, Previous View, which can be useful for returning 

quickly to the view before the current one. 
 

For convenience, the new Standard Views and View toolbars are shown below. 
 
 

 

 
 

Figures 2.24 and 2.25. Standard Views and View toolbars.  
 
 

2.3.8 Adding a Hole in the Arm Page 40 
 

9. In order to save the Part and not the Template, be sure to click File ⇒ Save As instead of Save.  
Change Save as type to Part.  The arm part can then be saved in the same location as the 
guard.  Be sure to save the arm in the same folder as the guard. 
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2.4.1 Sketching the Blade Page 42 
 

1. When creating a new part from a template, it is necessary to click Advanced in the New 
SolidWorks Document dialog box.  After clicking Advanced, the tutorial part template you 
created in the previous section should be available. 

 
 

2.4.5 Changing the Definition of the Extrusion Page 46 
 
1-3. Use Edit Feature instead of Edit Definition in order to update the definition of an existing 

feature. 
 

IN ADDITION – Use Edit Feature in Paragraph 6.3.4.7 as described above. 
 
 
3.2.3 Sketching and Cutting a Single Groove Page 58 

 
11. Tangent edge visibility is no longer set in the View⇒Display menu. In order to show tangent 

edges in the model, click Tools⇒Options.  In the System Options tab of the dialog box, click 
Display/Selection and choose the appropriate setting for viewing tangent edges under 
Part/Assembly tangent edge display. 

 
IN ADDITION – Tangent edge visibility is set throughout the tutorial, including paragraphs 4.2.6.3, 
4.2.6.3, 6.3.2.1, and 6.4.1.1.  
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3.2.4 Modeling More Grooves: Inserting a Linear Pattern Page 59 
 

3. Creating a Reference Axis is now done in the PropertyManager, which is shown below.  The Front 
and Right planes should appear in the Reference Entities list of the PropertyManager and Two 
Planes should be highlighted.  Click OK to create the axis. 

 

 
 

Figure 3.18. Reference Axis PropertyManager. 
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3.2.8 Changing the Color of the Handle Page 66-67 
 

2. Controlling the color of a part, face, or feature is done in the Color and Optics PropertyManager, 
which is shown below.  

3. In order to change the color of the entire handle (and not a face or feature), it is necessary to select 
the part by clicking the topmost item in the flyout Feature Manager Design Tree. 

 
 

 
 

Figure 3.29. Color and Optics PropertyManager. 
 
 



 7

3.3.4 Reopening the Sketch and Adding Dimensions Page 74 
 

10. Use the Confirmation Corner to exit the sketch.  In the top right of the Graphics Window, click 
the green check mark to accept the changes. 

 
IN ADDITION – Using the Confirmation Corner to exit a sketch is done in paragraph 6.4.1.7. 
 
 
4.1.1 Creating a New Assembly Document Pages 77 

 
3.  The FeatureManager design tree will not appear until section 4.1.2 
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4.1.2 Bringing the Rivet into the Sub-Assembly Pages 78-79 
 

1.  Parts are brought into assemblies in a slightly different manner. Instead of using 
Insert⇒Component⇒From File, the PropertyManager displays a message as shown below 
when a new assembly is opened.  If this message does not appear automatically, the menu item 
for assembling components is Insert⇒Component⇒Existing Part/Assembly.   

 
2.  Click Browse to select a saved part or subassembly, in this case rivet.  
 
3.  Instead of moving the cursor over the origin as described in the tutorial, simply click OK (the 

green check mark) in the PropertyManager to assemble the part so its origin is aligned with the 
assembly origin. 

 
 
 

 
 

PropertyManager message. 
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4.1.3 Bringing the Arm into the Assembly and Orienting It Page 80 
 

1.  The menu item for assembling components is Insert⇒Component⇒Existing Part/Assembly.  
Use Browse in the PropertyManager to find the part file. 

 
4. Moving and rotating components can no longer be done using the Tools⇒Component menu. 

Components can still be oriented by using the buttons in the Assembly toolbar, as described in 
the book, or by simply dragging a component with the left mouse button to move it.  Drag with 
the right mouse button to rotate a component. 

 
 
4.2.1 Creating a New Assembly and Inserting the Handle Page 86 
 

1. After creating a new assembly, the cutter sub-assembly may automatically appear for assembly. 
Since the handle should be assembled first, click the red ‘X’ in the corner to cancel the 
insertion. Continue with the assembly by inserting the handle part. 

 
 

4.2.4 Hiding an Object Page 89 
 

2. Select Hide instead of Hide Components to follow along with the tutorial. 
 

IN ADDITION – The commands Hide and Show are used throughout the tutorial, including paragraphs 
4.2.6.1, 4.3.5.2, 6.2.4.4, 7.1.3.4, and 7.1.3.9. 
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4.3.1 Checking for Interference Volumes Pages 93-94 
 

1. The Interference Detection control is now located in the PropertyManager, as shown below. Click 
OK to begin the analysis. 

 
 

 
 

Figure 4.25. Interference Detection PropertyManager. 
 
 

5.2.2 Checking the Options Settings Page 107 
 

1. To match the settings used in the tutorial, select the Display Style item on the left side of the 
System Options tab.  Under Display style for new views, select Hidden Lines Visible.  Under 
Tangent Edges in new views, select Visible. 

3. The options for Notes and Balloon can now be set separately. Set the both Note and Balloon list 
items in the Document Properties tab to match what is shown in the tutorial. 

 
 

5.2.5 Modifying the Lines of the Sheet Format Page 112 
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1. There is no longer an Edit⇒Sheet Format command. To edit (or compete editing) a sheet format, 
right-click on an open section of the drawing and select Edit Sheet Format (or Edit Sheet to 
complete the editing).  To see whether or not you are editing the format, the Status Bar at the 
lower right hand of the screen displays the current mode. 

 
IN ADDITION – Editing the format or sheet through the right mouse button is also used in paragraph 
5.3.1.2. 

 
5. The Symbol dialog box no longer requires clicking the Use Symbol button for  placing symbols. 
 
There is no Custom Sheet Format button when saving the format. SolidWorks will automatically 
save it as a custom format. 
 

IN ADDITION – Selecting a custom sheet format is similar to loading it, which is used in paragraph 
5.4.1.2. 
 
 
5.3.2 Adding a Named View Page 116 
 

1. The Named View toolbar button has been removed.  To insert a view (that was created in the 
model), click Model View in the Drawing Toolbar.  The properties of the view can be updated 
in the PropertyManager as described in the tutorial. 

 
 

5.4.2 Adding Orthographic and Isometric Views to the Drawing  
 Page 127 
 

3. If the view import in a 1:2 scale instead of the desired 1:4 as shown in the Status Bar, select each 
view and set the appropriate scale in the PropertyManager. 
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5.4.6 Adding a Bill of Materials Page 132-134 
 

2. A Bill of Materials can be inserted by clicking Insert⇒Tables⇒Bill of Materials.  The Bill of 
Materials PropertyManager appears, as shown below.  Set the appropriate properties to match 
the tutorial. 

 
 

 
 

Figure 5.31. Bill of Materials PropertyManager. 
 
5-7. A Bill of Materials is now edited directly in SolidWorks, without the use of Excel.  The 

commands and functionality are the same. 
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6.5.3 Creating a Coincident Mate Using SmartMates Page 171-174 
 

SmartMates, a simple and quick way to mate components in assemblies, has been integrated into the 
general method of creating mates with the use of keyboard shortcuts.  In the tutorial, instead of 
explicitly using the SmartMates feature, do the following in order to mate components quickly: 

• Hold down the ALT key. 
• Click and drag the feature that you would like to mate on one component. 
• Drag the component to the feature of the mating component. 
• Let go of the ALT key. 
• Click OK in the flyout dialog box. 
 

 
7.1.1 Setting Up the Document and Customizing the Interface  
 Page 180 
 

3. The Polygon toolbar button is no longer located in the Sketch toolbar.  If you would like to 
practice adding and removing buttons, the Move or Copy Entities button can be removed and 
replaced using the steps described in the tutorial.  Even though there is no Polygon button, be 
sure to add the Ellipse button. 

 
 

7.1.7 Creating the Loft Feature Pages 189-191 
 
SOFTWARE NOTICE – Ensure the latest software update of SolidWorks is installed on your machine for 
the loft feature to work properly.  At a minimum, Service Pack 4 (SP4) should be used. 
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7.1.8 Modeling the Round End Using a Dome Feature Page 191 
 

2. The Dome feature is now located in the PropertyManager, as shown below.  Follow the instructions 
in the tutorial to complete the dome feature. 

 
 

 
 

Figure 7.23. Dome PropertyManager. 
 
 

7.2.1 Creating a Radiated Surface Pages 193-194 
 
SOFTWARE NOTICE – Ensure the latest software update of SolidWorks is installed on your machine for 
the radiate surface feature to work properly.  At a minimum, Service Pack 4 (SP4) should be used. 
 

5. Edge<1> through Edge<10> (instead of Edge<6>) may appear in the Edges to Radiate field. 
Continue to create the radiate feature as described in the tutorial. 

 
 

7.3.2 Creating the Text Sketch Page 203 
 

7. Instead of locating the text point X Coordinate to 7/8, use 3/4 to better match the images shown in 
the tutorial. 

 
 

7.3.4 Changing the Color of the Cut-Extrude Feature Page 206 
 

2-3. There is no Apply button in the new Color and Optics PropertyManager. Click the green check 
mark to accept the color.  Then redo the process for changing the color of the handle part. 
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7.4.1 Setting up the Assembly Document Page 208 
 

1-3. The lofted handle part will automatically appear for placement in the assembly.  To locate the 
handle so that it is aligned with the origins of the assembly, simply click OK (the green check 
mark).  There is no need to show or hide the origins. 

 
 

7.4.2 Mating the Cutter Sub-Assembly with the Handle Page 210 
 

6. If tangent edges are not visible, they can be activated using Tools⇒Options.  Instead, a quicker 
method is to activate Shaded With Edges in the View toolbar to show tangent edges while the 
part is shaded. 
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7.4.3 Modeling the Rectangular Hole Using the Cavity Feature 
 Page 211-212 
 

2. To edit a part within an assembly, click the Edit Component in the Assembly toolbar while the 
part is selected or Right-click the part and select Edit Part. 

 
3. To begin the Cavity feature, click Insert⇒Mold⇒Cavity. 
 
4. The Cavity feature is now located in the PropertyManager, as shown below. 
 
 

 
 

Figure 7.46. Cavity PropertyManager. 


